]> git.tuebingen.mpg.de Git - lopsub.git/blobdiff - debian/rules
debian: Create an md5sums control file.
[lopsub.git] / debian / rules
index 3ba7a7480068a15683befe1c74381103a2e72238..387b14c917d8e7563d8898696ba1294463bc95a9 100755 (executable)
@@ -2,8 +2,7 @@
 # Invoke each target with `./debian/rules <target>'.  All targets should be
 # invoked with the package root as the current directory.
 
-sourcepackage := liblopsub
-package := liblopsub1
+package := liblopsub1t64
 devpackage := liblopsub-dev
 
 define checkdir
@@ -19,6 +18,10 @@ DOCS_DIR := $(DESTDIR)/usr/share/doc/$(package)
 DEVDOCS_DIR := $(DEVDIR)/usr/share/doc/$(devpackage)
 TRIPLET := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
+# activate the dh sequencer
+%:
+       dh "$@"
+
 build-arch:
        $(checkdir)
        $(MAKE)
@@ -43,19 +46,21 @@ binary: build
        mv $(TMPDIR)/usr/lib-$(TRIPLET) $(TMPDIR)/usr/lib/$(TRIPLET)
        dh_install -p $(package)
        dh_install -p $(devpackage)
+       dh_lintian
        $(MAKE_DIR) $(DESTDIR)/DEBIAN $(DOCS_DIR) $(DEVDOCS_DIR)
        echo 'activate-noawait ldconfig' > $(DESTDIR)/DEBIAN/triggers
        $(INST_FILE) debian/copyright $(DOCS_DIR)/copyright
        $(INST_FILE) debian/copyright $(DEVDOCS_DIR)/copyright
        $(INST_FILE) debian/changelog $(DOCS_DIR)/changelog.Debian
        $(INST_FILE) debian/changelog $(DEVDOCS_DIR)/changelog.Debian
-       gzip -f9 $(DOCS_DIR)/changelog.Debian
-       gzip -f9 $(DEVDOCS_DIR)/changelog.Debian
+       gzip -fn9 $(DOCS_DIR)/changelog.Debian
+       gzip -fn9 $(DEVDOCS_DIR)/changelog.Debian
        dh_makeshlibs
        dh_shlibdeps
        dh_strip
        dh_shlibdeps
        dh_gencontrol
+       dh_md5sums
        dh_builddeb
 
 binary-indep binary-arch: binary