]> git.tuebingen.mpg.de Git - lopsub.git/blobdiff - debian/rules
debian: Prefer https over http and git.
[lopsub.git] / debian / rules
index 3ba7a7480068a15683befe1c74381103a2e72238..94248ff3591019428156d16993213606d9c35369 100755 (executable)
@@ -3,7 +3,7 @@
 # invoked with the package root as the current directory.
 
 sourcepackage := liblopsub
-package := liblopsub1
+package := liblopsub1t64
 devpackage := liblopsub-dev
 
 define checkdir
@@ -43,14 +43,15 @@ binary: build
        mv $(TMPDIR)/usr/lib-$(TRIPLET) $(TMPDIR)/usr/lib/$(TRIPLET)
        dh_install -p $(package)
        dh_install -p $(devpackage)
+       dh_lintian
        $(MAKE_DIR) $(DESTDIR)/DEBIAN $(DOCS_DIR) $(DEVDOCS_DIR)
        echo 'activate-noawait ldconfig' > $(DESTDIR)/DEBIAN/triggers
        $(INST_FILE) debian/copyright $(DOCS_DIR)/copyright
        $(INST_FILE) debian/copyright $(DEVDOCS_DIR)/copyright
        $(INST_FILE) debian/changelog $(DOCS_DIR)/changelog.Debian
        $(INST_FILE) debian/changelog $(DEVDOCS_DIR)/changelog.Debian
-       gzip -f9 $(DOCS_DIR)/changelog.Debian
-       gzip -f9 $(DEVDOCS_DIR)/changelog.Debian
+       gzip -fn9 $(DOCS_DIR)/changelog.Debian
+       gzip -fn9 $(DEVDOCS_DIR)/changelog.Debian
        dh_makeshlibs
        dh_shlibdeps
        dh_strip