]> git.tuebingen.mpg.de Git - lopsub.git/blobdiff - debian/rules
debian: Remove an unused variable from rules file.
[lopsub.git] / debian / rules
index 3b5e4f13a40f5344b0cba4b0eeb2ebf117910bed..c058ac10c119612f6f232d198748d61a397ec76a 100755 (executable)
@@ -2,7 +2,6 @@
 # Invoke each target with `./debian/rules <target>'.  All targets should be
 # invoked with the package root as the current directory.
 
-sourcepackage := liblopsub
 package := liblopsub1t64
 devpackage := liblopsub-dev
 
@@ -19,6 +18,10 @@ DOCS_DIR := $(DESTDIR)/usr/share/doc/$(package)
 DEVDOCS_DIR := $(DEVDIR)/usr/share/doc/$(devpackage)
 TRIPLET := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
+# activate the dh sequencer
+%:
+       dh "$@"
+
 build-arch:
        $(checkdir)
        $(MAKE)
@@ -43,6 +46,7 @@ binary: build
        mv $(TMPDIR)/usr/lib-$(TRIPLET) $(TMPDIR)/usr/lib/$(TRIPLET)
        dh_install -p $(package)
        dh_install -p $(devpackage)
+       dh_lintian
        $(MAKE_DIR) $(DESTDIR)/DEBIAN $(DOCS_DIR) $(DEVDOCS_DIR)
        echo 'activate-noawait ldconfig' > $(DESTDIR)/DEBIAN/triggers
        $(INST_FILE) debian/copyright $(DOCS_DIR)/copyright