got rid of GSL requirement