build: Add two more warning options.
authorAndre Noll <maan@tuebingen.mpg.de>
Tue, 7 Jun 2016 14:23:36 +0000 (16:23 +0200)
committerAndre Noll <maan@tuebingen.mpg.de>
Sun, 21 Aug 2016 19:13:25 +0000 (21:13 +0200)
commit1c6346c95e20aaff69e27ecb6deacbd496000dca
tree9253ac2d9e61c3a66c2ccd2f65217d7175652649
parente9e6450e1a8ece2ff879523516fefd6576a76521
build: Add two more warning options.

Both -Wunused-parameter and -Wshadow were added to gcc long ago. In
particular gcc-4.6.3, which ships with Ubuntu-12.04, supports them. It
should thus be safe to enable both warnings unconditionally.
Makefile