]> git.tuebingen.mpg.de Git - tfortune.git/blobdiff - debian/rules
Fix cross build.
[tfortune.git] / debian / rules
index 03a9279753a10aa9360c8da3f7a714d9d53861f5..a360dc702b65671ab500d9cba80b5deef76ff4d9 100755 (executable)
@@ -1,13 +1,18 @@
 #!/usr/bin/make -f
 
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+include /usr/share/dpkg/architecture.mk
+DPKG_EXPORT_BUILDTOOLS=1
+include /usr/share/dpkg/buildtools.mk
+
 %:
        dh "$@"
 
 # plain dh_auto_configure uses options which configure does not understand
 override_dh_auto_configure:
        ./configure --prefix=/usr --bindir=/usr/games \
-               --datadir=/usr/share/games
+               --datadir=/usr/share/games --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
 # needed because dh_autoreconf overwrites our configure wrapper
 override_dh_autoreconf:
-       $(MAKE) configure.sh
+       $(MAKE) config.h.in configure.sh