build: .a files do not need to be executable.
authorAndre Noll <maan@tuebingen.mpg.de>
Sun, 3 Mar 2019 21:21:26 +0000 (22:21 +0100)
committerAndre Noll <maan@tuebingen.mpg.de>
Thu, 14 Mar 2019 13:11:03 +0000 (14:11 +0100)
We currently install liblopsub.a with mode 755, but the executable
bit is not needed. In fact, lintian complains about this.

Makefile

index 2ff12fa..de6badf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -101,7 +101,7 @@ install: liblopsub.a lopsub.7
        $(INSTALL) -d $(DESTDIR)$(PREFIX)/lib $(DESTDIR)$(PREFIX)/include \
                $(DESTDIR)$(PREFIX)/man/man1 $(DESTDIR)$(PREFIX)/man/man5 \
                $(DESTDIR)$(PREFIX)/man/man7 $(DESTDIR)$(PREFIX)/bin
-       $(INSTALL) -m 755 liblopsub.a $(DESTDIR)$(PREFIX)/lib
+       $(INSTALL) -m 644 liblopsub.a $(DESTDIR)$(PREFIX)/lib
        $(INSTALL) -m 755 lopsubgen $(DESTDIR)$(PREFIX)/bin
        $(INSTALL) -m 644 lopsub.h $(DESTDIR)$(PREFIX)/include
        $(INSTALL) -m 644 lopsub-internal.h $(DESTDIR)$(PREFIX)/include