web: Streamline INSTALL.
authorAndre Noll <maan@tuebingen.mpg.de>
Sat, 12 Sep 2020 12:27:16 +0000 (14:27 +0200)
committerAndre Noll <maan@tuebingen.mpg.de>
Tue, 22 Sep 2020 19:28:31 +0000 (21:28 +0200)
It was a bit too detailed, and inconsistent with respect to usage
of sudo. Also the formatting of the commands and the font usage was
inconsistent.

Provide a link to the lopsub homepage and mention that m4 is required
while at it.

INSTALL

diff --git a/INSTALL b/INSTALL
index ddac9d0..b92a083 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -1,31 +1,30 @@
-As the bare minimum, you'll need gcc-4 and gnu make to install
-libosl. lopsub is needed to build the oslfsck executable and to
-generate its man page. Download and install lopsub with
+Besides a working C compiler, gnu m4, gnu make and the
+[lopsub](http://people.tuebingen.mpg.de/maan/lopsub/) library must be
+installed to to build and install this package. Download and install
+lopsub with
 
-       git clone git://git.tuebingen.mpg.de/lopsub
-       cd lopsub && make && sudo make install
+               git clone git://git.tuebingen.mpg.de/lopsub
+               cd lopsub && make && sudo make install
 
 If everything mentioned above is available on your system, type
 
                make
 
-to build the library, the oslfsck executable and the man page. Then
-type
+to build libosl. Then type
 
-               make install
+               sudo make install
 
-as root to install libosl, oslfsck and the man page. Finally, update
-the library cache by running
+to install. Finally, update the library cache by running
 
                ldconfig
 
-The default installation prefix is /usr/local. Use
+The default installation prefix is `/usr/local`. Use
 
                make install PREFIX=/somewhere/else
 
-to install in /somewhere/else instead.
+to install in `/somewhere/else` instead.
 
-The make targets in the web/ directory are used for web page generation
+The make targets in the `web/` directory are used for web page generation
 and are not needed to compile, install or use libosl. In order to
 make these targets the following additional tools are needed: