build: Fix check for lopsub.
authorAndre Noll <maan@tuebingen.mpg.de>
Sat, 8 Jul 2017 16:36:03 +0000 (18:36 +0200)
committerAndre Noll <maan@tuebingen.mpg.de>
Fri, 14 Jul 2017 13:37:05 +0000 (15:37 +0200)
If the lopsub library is not installed, HAVE_LOPSUB should be set to
"no".  The current code in configure.ac gets this wrong, causing the
configure script to succeed even if the library is not installed.

configure.ac

index a589613..ee1c3d8 100644 (file)
@@ -76,7 +76,7 @@ STASH_FLAGS
 LIB_ARG_WITH([lopsub], [-llopsub])
 HAVE_LOPSUB=yes
 AC_CHECK_HEADER(lopsub.h, [], [HAVE_LOPSUB=no])
-AC_CHECK_LIB([lopsub], [lls_merge], [], [HAVE_LOPSUB=yes])
+AC_CHECK_LIB([lopsub], [lls_merge], [], [HAVE_LOPSUB=no])
 if test $HAVE_LOPSUB = no; then AC_MSG_ERROR([
        The lopsub library is required to build this software, but
        the above checks indicate it is not installed on your system.