Introduce LIST_HEAD macro and use it in audiod_command.
[paraslash.git] / REQUIREMENTS
1 Requirements
2 ============
3
4 In any case you need
5
6 - libosl: If you are compiling from git the osl sources should
7 have been cloned automatically. It is also available for
8 download from http://git.tuebingen.mpg.de/osl. Or run the
9 command "git clone git://git.tuebingen.mpg.de/osl"
10 - gcc, the gnu compiler collection (shipped with distro): gcc-3.3
11 or newer is required.
12 - gnu make (shipped with disto, might be called gmake)
13 - bash (most likely already installed)
14 - A decent version of grep. Solaris' /bin/grep is not good enough,
15 /usr/xpg4/bin/grep is fine though.
16 - openssl (needed by server, client): usually shipped with
17 distro, but you might have to install the "development package"
18 (called libssl-dev on debian systems) as well:
19 http://www.openssl.org/
20 - help2man (for man page creation) ftp://ftp.gnu.org/pub/gnu/help2man
21 - software mixing, e.g. ALSA and the direct mixing plugin (dmix)
22
23 Optional features:
24
25 - *mp3*: The mp3 decoder of para_filter is based on libmad:
26 http://www.underbit.com/products/mad/. If you prefer to
27 use the libmad package provided by your distributor, make
28 sure to install the corresponding development package as
29 well. It is called libmad0-dev on debian-based systems.
30 Note that libmad is not necessary for the server side,
31 i.e. for sending mp3 files.
32
33 - *id3 tags*:
34 For version-2 id3 tag support, you'll need libid3tag which
35 is also available through the above link (alternatively:
36 install package libid3tag0-dev). Without libid3tag, only
37 version one tags are recognized.
38
39 - *ogg vorbis*: For ogg vorbis streams you'll need libogg,
40 libvorbis, libvorbisfile: http://www.xiph.org/downloads/.
41 The corresponding Debian packages are called libogg-dev
42 libvorbis-dev, other distributors chose similar names.
43
44 - *aac*:
45 For aac files (m4a) you'll need libfaad. Get it at
46 http://www.audiocoding.com/.
47 Debian package: libfaad-dev.
48
49 - On Linux, you'll need to have ALSA's development package
50 installed. The Debian package is called libasound2-dev.
51
52 Hacking the source:
53
54 - gengetopt: ftp://ftp.gnu.org/pub/gnu/gengetopt/
55 - autoconf: ftp://ftp.gnu.org/pub/gnu/autoconf/
56 - git http://git.or.cz/
57 - grutatxt http://www.triptico.com/software/grutatxt.html
58 - doxygen http://www.stack.nl/~dimitri/doxygen/
59 - global ftp://ftp.gnu.org/pub/gnu/global
60 - m4: ftp://ftp.gnu.org/pub/gnu/m4/