manual: libosl is optional.
authorAndre Noll <maan@tuebingen.mpg.de>
Fri, 14 Jul 2017 13:39:28 +0000 (15:39 +0200)
committerAndre Noll <maan@tuebingen.mpg.de>
Sat, 15 Jul 2017 23:09:09 +0000 (01:09 +0200)
Even without libosl, the build succeeds (only para_server won't be
built). Hence libosl should be listed as optional software. This
commit moves the item out of the list of mandatory packages.

web/manual.md

index c31e1d3..1322e64 100644 (file)
@@ -301,12 +301,6 @@ Requirements
 
 In any case you will need
 
-- [libosl](http://people.tuebingen.mpg.de/maan/osl/). The _object
-storage layer_ library is used by para_server. To clone the source
-code repository, execute
-
-               git clone git://git.tuebingen.mpg.de/osl
-
 - [lopsub](http://people.tuebingen.mpg.de/maan/lopsub/). The long
 option parser for subcommands generates the command line and config
 file parsers for all paraslash executables. Clone the source code
@@ -330,6 +324,12 @@ from templates by the m4 macro processor.
 
 Optional:
 
+- [libosl](http://people.tuebingen.mpg.de/maan/osl/). The _object
+storage layer_ library is used by para_server. To clone the source
+code repository, execute
+
+               git clone git://git.tuebingen.mpg.de/osl
+
 - [openssl](http://www.openssl.org/) or
 [libgcrypt](ftp://ftp.gnupg.org/gcrypt/libgcrypt/).  At least one
 of these two libraries is needed as the backend for cryptographic