require bash-4.3